Welcome to the #dominoforever Product Ideas Lab! The place where you can submit product ideas and enhancement request. We encourage you to participate by voting on, commenting on, and creating new ideas. All new ideas will be evaluated jointly by the IBM & HCL Product Management & Engineering teams, and the next steps will be communicated. While not all submitted ideas will be executed upon, community feedback will play a key role in influencing which ideas are and when they will be implemented.

For more information and upcoming events around #dominoforever, please visit our Destination Domino page.


Automatically enable latest ODS-Version for all templates and future databases in local DataDir after Install

Many many people (customers and partners) would benefit if IBM/HCL would deploy the latest ODS-Version automatically to all existing templates and future databases after Install of Notes.

You could go even one step deeper to have an additional "install parameter" like ODSUPGRADE=1, which ensures that all existing templates (shared data if multiuser install | data if singleuser install) will be upgraded during install process AND all future databases will use latest ODS by adding CREATE_R10_DATABASES=1 to all existing notes.ini's and stub notes.ini (if multiuser install). If you would also add NSF_UpgradeODS=1 to existing notes.ini's, then also all existing databases will be upgraded during next IBM Notes Client Sessions of the users in the background.

That would be a great performance and stability improvement.

  • Avatar32.5fb70cce7410889e661286fd7f1897de Guest
  • Jul 16 2018
  • Under Consideration
  • Attach files
  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    16 Jul 12:08

    I agree with this Idea

  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    03 Aug 06:43

    Like this. Including automatic Update (maybe to be conservative, 1 Version back - and no need to set notes.ini in every release if possible.).

  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    21 Aug 12:20

    Nice but critical IMHO

  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    01 Sep 10:51

    This needs to be a server INI setting to force all NSFs (existing and newly created) to a specific version:

     

    ODS_MIN_VERSION=53

    ODS_MIN_VERSION=55

    ODS_MIN_VERSION=LATEST

  • Avatar40.8f183f721a2c86cd98fddbbe6dc46ec9
    Guest commented
    15 Nov 10:54

    One minor side notes NSF_UpgradeODS=1 does not exist! The right parameter is NSF_UpdateODS=1.
    I checked the string resources and it looks like the "Upgrade" was a typo somewhere which multiple people copied into their blogs and presentations.

    ( Daniel Nashed / blog.nashcom.de)